Compatible Controller:

  • FBLI-V-LV4
  • FBLI-V-LV4A

Compatible Controller:

  • All models of LMC Series

Software Versions:

  • EZCAD2.14.11
  • EZCAD2.14.10
  • EZCAD2.14.9
  • EZCAD2.14.6
  • EZCAD2.9.6
  • EZCAD2.7.6

Compatible Controller:

  • All models of DLC Series

Note: 

1. Please do not overwrite old files because new software does not include machine parameters.

2. If you have any technical questions, please feel free to contact LASERCHINA at any time.